Problem

Die Verbindung zur Connect/SAS-Anwendung kann nicht mehr aufgebaut werden.


Ursache

Das Problem tritt häufig beim einem Update vom SAS Client v3 auf SAS Client v4 auf.


Lösung

Der SAS Client v4 muss neu installiert werden. Gehen Sie dazu wie folgt vor:


Wenn der SAS Client v4 bereits ausgeführt wurde dann wird dieser Ordner erstellt: %Temp%\CitrixTPv3. Ansonsten SAS Client v4 aufrufen und den Schritt 1 abwarten aber nicht auf "Start" drücken. Es kann auch sein, dass der Benutzer keine Adminrechte hatte und entsprechend der SAS Client v4 mit dem Administrator gestartet wurde, dann werden die Dateien im Temp-Ordner vom Administrator entpackt (C:\Users\Administrator\Appdata\Local\Temp\CitrixTPv3).
 Anschließend den SAS Client v4 über "Abbrechen" beenden.

Über die Systemsteuerung Citrix und Thinprint manuell deinstallieren (falls die Einträge vorhanden sind).

Die CitrixWorkspaceApp.exe (siehe Screenshot oben) ist ein Container und kann mit Winrar/7zip/Winzip entpackt werden. 

Darin befindet sich die ReceiverCleanupUtility.exe welche als Uninstaller den Citrix-Client restlos vom PC entfernt.

Hinweis:


Die heruntergeladene Datei ausführen und einen Ordner wählen wohin 7-Zip Portable entpackt werden soll. Danach die 7-ZipPortable.exe starten, bis zum Temp Ordner navigieren und die CitrixWorkspaceApp.exe entpacken.


Dieser Hinweis von 7-Zip kann ignoriert werden:


Anschließend den entpackten CitrixWorkspaceApp Ordner aufrufen und dort die ReceiverCleanupUtility.exe als Administrator ausführen


Deinstallation abwarten und danach ganz normal den SAS Client v4 wieder als Administrator ausführen und die Installation starten.

Hinweis: Es kann vorkommen, dass nach dieser Aktion Thinprint erst nach einem Neustart des PCs sauber startet.