Problem:

Beim Mailversand aus dem BRZ Programm erscheint folgende oder ähnliche Fehlermeldung


Ursache:

  • Zwei verschiedene Office Versionen auf dem PC 
  • Ältere Office Version vor Neuinstallation nicht richtig deinstalliert 
  • Neue Office Version über ältere Office Version installiert 
  • Vorinstallatin von Office auf dem PC noch teils vorhanden 
  • 32 Bit Office durch 64 Bit Office ersetzt 


Lösung:

Interface not registered (Exception from HRESULT: 0x80040155) - Microsoft Office/Outlook Error - Webmakers 


hier der Inhalt der oben genannten Webseite:


This can be a particularly nasty problem. Follow through the steps: 

Register Ole32.dll 

Make sure part of Microsoft Office (the Ole32.dll file that is located in the %windir%\System32folder) is registered correctly in the Windows registry: 

  1.     1. Click Start, and then type Command Prompt, in appeared list, right-click Command Prompt and select Run as Administrator 
  2.     2. In Command Prompt window type the following command and press Enter  
    1.             For 32 bit Windows: regsvr32.exe %windir%\System32\Ole32.dll 
    2.             For 64 bit Windows: %systemroot%\SysWoW64\regsvr32.exe %windir%\SysWoW64\Ole32.dll 
  3.     3. In the RegSvr32 dialog box, click OK. 

Then follow the 3 steps through below from fix the interface to ensure MSOUTL.LIB is registered (the final step usually being the most important). 

Registry Fixes: 

Step through the following sections. 

 It is always wise to backup your Windows registry before making any manual changes. 

Outlook Version Numbers 

Use this table as a reference as guided in the following sections. 

Outlook 

Version 

Outlook 2003 

9.2 

Outlook 2007 

9.3 

Outlook 2010 

9.4 

Outlook 2013 

9.5 

Outlook 2016 

9.6 

1. Fix the Interface 

  1.     1. Access the Windows Registry Editor via Start > Run > Type Cmd and Enter > Type RegEdt32 and Enter. 
  2.     2. Navigate to each of the keys that exist (depends on if using the 32 or 64 bit version of Outlook/Windows):  
    1.             HKEY_CLASSES_ROOT\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib 
    2.             HKEY_LOCAL_MACHINE\SOFTWARE\Classes\WOW6432Node\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib 
    3.             HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Classes\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib 
  3.     3. Find a (Default) entry with the value {00062FFF-0000-0000-C000-000000000046} 
  4.     4. Compare and correct the Version value against the Outlook version numbers table. 

2. Fix the TypeLib 

  1.     1. Navigate to HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046} 
  2.     2. Delete the version keys (e.g. 9.5) for any version of Outlook that is not installed on your system, based on the version table provided.  
    1.           For example, if you are not using Outlook 2013 then remove the 9.5 entry. If you are not using Outlook 2010 then remove the the 9.4 entry. 
    2.           DO NOT DELETE the entry for the version that was specified in the last step of the previous fix the interface section. 

3. Ensure MSOUTL.LIB is Registered 

  1.     1. In the previous fix the typelib section, make sure that the registry key value ending with MSOUTL.OLB is pointing to a valid file location. The key location should be something like HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.6\0\Win64 
  2.     2. We now need to make sure that file is properly registered.  
    1.           1. Download regtlibv12.exe to your computer 
    2.           2. Go the Windows Start Menu and type cmd. 
    3.           3. In the search results, right-click cmd.exe and select Run as Administrator... 
    4.           4. Change directory to where you downloaded regtlibv12.exe, eg: cd %USERPROFILE%\Downloads 
    5.           5. Execute the following command, where <msoutl.olb file> is the value taken from step #3:
                regtlibv12.exe "<msoutl.olb file>".
      For example:
                 regtlibv12.exe "C:\Program Files\Microsoft Office\root\Office16\MSOUTL.OLB" 
  3.     3. Run Outlook. 

 

Aus <https://webmakers.co.nz/interface-not-registered-exception-from-hresult-0x80040155-microsoft-office-outlook-error/>  

 

 
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 Problem mit Microsoft Office 

'TYPE_E_CANTLOADLIBRARY' - Fehler im Connector4VX nachdem eine neuere Microsoft Office-Version deinstalliert und eine ältere Microsoft Office-Version installiert wurde. 

 

Microsoft Word: Das COM-Objekt des Typs „Microsoft.Office.Interop.Word.ApplicationClass“ kann nicht in den Schnittstellentyp „Microsoft.Office.Interop.Word._Application“ umgewandelt werden. 

Microsoft Excel: Das COM-Objekt des Typs „Microsoft.Office.Interop.Excel.ApplicationClass“ kann nicht in den Schnittstellentyp „Microsoft.Office.Interop.Excel._Application“ umgewandelt werden. 

Microsoft Outlook: Das COM-Objekt des Typs „Microsoft.Office.Interop.Outlook.ApplicationClass“ kann nicht in den Schnittstellentyp „Microsoft.Office.Interop.Outlook._Application „umgewandelt werden. 

 

Ursache: Registry-Einträge der neueren Version von Microsoft Office bleiben nach der Deinstallation von Microsoft Office bestehen. 

Lösung: Im Registrierungseditor den entsprechenden Registry-Pfad öffnen. Alle untergeordneten Schlüssel entfernen, die nicht Ihrer installierten Version entsprechen. 

 

Microsoft Word 

Registry-Pfad: HKEY_CLASSES_ROOT\TypeLib\{00020905-0000-0000-C000-000000000046} 

Version → Schlüssel:  Word 2003 → 8.3 / Word 2007 → 8.4 / Word 2010 → 8.5 / Word 2013 → 8.6 / Word 2016 → 8.7 

 

Microsoft Excel 

Registry-Pfad: HKEY_CLASSES_ROOT\TypeLib\{00020813-0000-0000-C000-000000000046} 

Version → Schlüssel:  Excel 2003 → 1.5 / Excel 2007 → 1.6 / Excel 2010 → 1.7 / Excel 2013 → 1.8 / Excel 2016 → 1.9 

 

Microsoft Outlook 

Registry-Pfad: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046} 

Version → Schlüssel: Outlook 2003 → 9.2 / Outlook 2007 → 9.3 / Outlook 2010 → 9.4 / Outlook 2013 → 9.5 / Outlook 2016 → 9.6 

 

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Existiert der unten rot markierte Bereich (verwaister Eintrag der nicht mehr existenten 32bit Version)? Wenn ja: Den zunächst sichern und dann löschen.